注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

中华神鸟

QQ:935658701

 
 
 

日志

 
 

【转】[wtkbuild] Cannot find jar or jar.exe in C:\ProgramFiles\Java\jre1.6.0_03\bin, preverify will most likely fail  

2014-07-18 09:34:35|  分类: javame |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

I've been trying to configure Eclipse with EclipseME, Antenna, and J2ME 
Polish for some time now, and keep running into problems.
When right-clicking on the project and select "J2ME" "Export Antenna 
Build Files", three files are created (build.xml, 
eclipseme-build.properties, and eclipseme-build.xml). When 
right-click "build.xml" and select "Run As" "Ant Build", receiving 
the following error:

"[wtkbuild] Cannot find jar or jar.exe in C:\Program 
Files\Java\jre1.6.0_03\bin, preverify will most likely fail."

On my system, "jar.exe" is located in "jdk1.6.0_03", not "jre1.6.0_03", 
yet for some reason, it's searching the JRE path. have no idea how to 
correct this.
-----------------------------------------------------------------------------------------------------
 
 
Re:I seem to have fixed the problem via the following steps:

1. Open Preferences by selecting "Windows" "Preferences".
2. Select "Java" "Installed JREs".
3. Click "Add", and "Browse" beside the "JRE home directory" text 
field.
4. Locate the JDK, then click "Okay". The remaining fields should 
automatically be filled with the correct information.
5. Click "Okay" to save the changes.
6. When you return to the "Preferences" window, you need to set the 
newly added JDK as the default, so mark the checkbox in front of the new 
JDK option, then click "Okay" to save the preferences.

This seems to have fixed the error from occurring on both of my systems.
----------------------------------------------
使用antenna打包成功,但console里显示有如下的警告信息
"[wtkbuild] Cannot find jar or jar.exe in C:\Program 
Files\Java\jre1.6.0_03\bin, preverify will most likely fail."

问题原因:eclipse使用的不是jdk中的文件,而是jre的,将eclipse中相关的配置改为jdk的安装目录即可。修改后记得把新添加项选中,而原来jre的项可以删除,删除后可能出现下面的问题:

Specified VM install not found: type Standard VM, name jre6

解决方法:关闭eclipse,删除工作目录下--\.metadata\.plugins\org.eclipse.debug.core\.launches
文件夹中的所有文件;
重启eclipse,ok

 

原文地址:http://blog.sina.com.cn/s/blog_68f48e050100jj9r.html

http://blog.sina.com.cn/s/blog_6c98e96d0101i9v5.html

  评论这张
 
阅读(92)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017